Cli codefresh create token and web api POST /auth/key both fail with same error

I’m using codefresh onprem 2.2.7, and I think the tools for programatically creating API keys don’t work - the error messages are similar between both the cli and web api.

I’m trying these commands:

% codefresh create token dave-test-token --subject dave-test-token --type runtime-environment
Error: Required object not found
% curl  \
    -X POST \
    -H "Authorization: ${CODEFRESH_API_KEY}" \
    -H 'Content-Type: application/json; charset=utf-8' \
    -d '{}' \
  "status": 404,
  "code": "1002",
  "name": "NOT_FOUND_ERROR",
  "message": "Required object not found",
  "context": {}

I’m fuzzy on what the error message “Required object not found” means, especially in the web api case, where I’m passing it an empty json object, and that’s exactly what’s documented in y’all’s own documentation at Codefresh API

I think its a bug in the web api, that the cli is using too.

Other notes:

  • Codefresh onprem version 2.2.7
  • Codefresh cli versions 0.87.2 and 0.87.3
  • CODEFRESH_API_KEY - tried both service worker keys and personal keys, verified that auth works with both.


If you are using the on-prem version of Codefresh, you probably have a dedicated Slack support channel with us, as well as an account manager.

I would suggest to escalate this via your support channel, in order to get much faster responses and dedicated engineering effort.